Detailing World  

Go Back   Detailing World > Detailing Products > Tools -Machine polishers, Pressure Washers, Detailing Equipment & Microfiber
DW Home Forum Home Merchandise Store Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Tools -Machine polishers, Pressure Washers, Detailing Equipment & Microfiber Sponsored by Detailed Clean : www.DetailedClean.co.uk – | Bilt Hamber | Dodo Juice | Nanolex | Sonus | Wolfs Chemicals + More | Loyalty Scheme Discounts |

Reply
 
Thread Tools Display Modes
Old 04-03-2018, 07:41 PM   #31
Peter77
Orbital Oracle
 
Peter77's Avatar
 
Join Date: May 2016
Posts: 743
Thanks: 65
Thanked 330 Times in 282 Posts
If helps, mine was already greased up with what looks like vaseline


Sent from my iPhone using Tapatalk
Peter77 is offline   Reply With Quote
Old 04-03-2018, 08:38 PM   #32
M300JDG
Washmitt Meister
 
M300JDG's Avatar
 
Join Date: Oct 2017
Posts: 191
Thanks: 44
Thanked 75 Times in 51 Posts
Garage
I’ve seen a few bits online saying with this particular model you need to use a hose extension push connector rather than going straight into the machine, what’s the point in that!
If the OEM hose broke you would need to replace it so that is tosh. Not impressed with my first Karcher so far, very plastic and cheap but did clean my motor very nicely.


Sent from my iPhone using Tapatalk
M300JDG is offline   Reply With Quote
Old 04-03-2018, 10:48 PM   #33
GleemSpray
OCD Sufferer (Obsessive Car Detailer)
 
GleemSpray's Avatar
 
Join Date: Jan 2014
Location: South Manchester UK
Posts: 3,786
Thanks: 448
Thanked 2,362 Times in 1,596 Posts
Quote:
Originally Posted by M300JDG View Post
I’ve seen a few bits online saying with this particular model you need to use a hose extension push connector rather than going straight into the machine, what’s the point in that!
If the OEM hose broke you would need to replace it so that is tosh. Not impressed with my first Karcher so far, very plastic and cheap but did clean my motor very nicely.


Sent from my iPhone using Tapatalk
I didn't use any special connectors with my K4 Eco. Just disconnected the OEM hose from the base of the reel and replaced it with a Direct Hoses one and it works fine.
GleemSpray is offline   Reply With Quote
Old 07-03-2018, 12:52 PM   #34
M300JDG
Washmitt Meister
 
M300JDG's Avatar
 
Join Date: Oct 2017
Posts: 191
Thanks: 44
Thanked 75 Times in 51 Posts
Garage
Problem solved gents, I took it back and got new one! The chap in Screwfix said they are getting the new model k4 retuned quite a bit for a variety of issues.


Sent from my iPhone using Tapatalk
M300JDG is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 09:07 PM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
DTO Garage vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors
Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
DTO Garage vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors