Detailing World  

Go Back   Detailing World > Detailing Products > Interior & Glass
DW Home Forum Home Merchandise Store Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Interior & Glass Discuss All your Interior Issue - Dash - Seats and All the Car Glass Areas - Interior Dressing, Leather etc

Reply
 
Thread Tools Display Modes
Old 14-02-2018, 04:47 PM   #1
planehazza
Sponge Jockey
 
Join Date: Jan 2018
Posts: 47
Thanks: 4
Thanked 2 Times in 2 Posts
H2GO - Not as expected?

Can someone tell me if I've applied it wrong? I cleaned the glass by hand during the wash as normal, then cleaned it with a glass cleaning cloth and Fast Glass. I buffed that out, then applied the H20 via a foam applicator, rubbing in circles ensuring I covered the whole panel. I left it for 10 mins before removing with a clean, short pile MF cloth.

The water doesn't sheet off as well as I was expecting, and I get wiper blade shudder when there's only a little water to wipe away.

I didn't clay the glass or anything, as it's only 6 weeks old so I figured there's not going to be much in the form of bonded contaminants yet. Perhaps that's where I messed up?
planehazza is offline   Reply With Quote
Old 14-02-2018, 04:54 PM   #2
BrummyPete
OCD Sufferer (Obsessive Car Detailer)
 
BrummyPete's Avatar
 
Join Date: Jun 2010
Posts: 1,658
Thanks: 306
Thanked 635 Times in 562 Posts
I normally clay and use barkeepers friend before putting h2go on Windows, I have tried it without any prep before and didn't find it too bad but did have smears, maybe try cleaning your wiper blades?

Sent from my SM-T719 using Tapatalk
BrummyPete is offline   Reply With Quote
Old 14-02-2018, 05:01 PM   #3
Andyblue
OCD Sufferer (Obsessive Car Detailer)
 
Andyblue's Avatar
 
Join Date: Jun 2017
Location: In the Dog house
Posts: 3,768
Thanks: 1,272
Thanked 1,741 Times in 1,544 Posts
The powder version of Bar Keepers friend is brilliant stuff

I stopped using any products on my windscreen due to smearing and some judder at low speeds - I tried everything I could think of and always had the issue...

I use my stuff on side / rear windows now and it’s great.
Andyblue is offline   Reply With Quote
Old 14-02-2018, 05:13 PM   #4
percymon
OCD Sufferer (Obsessive Car Detailer)
 
Join Date: Jun 2007
Posts: 1,387
Thanks: 171
Thanked 709 Times in 595 Posts
Garage
Quote:
Originally Posted by planehazza View Post
Can someone tell me if I've applied it wrong? I cleaned the glass by hand during the wash as normal, then cleaned it with a glass cleaning cloth and Fast Glass. I buffed that out, then applied the H20 via a foam applicator, rubbing in circles ensuring I covered the whole panel. I left it for 10 mins before removing with a clean, short pile MF cloth.

The water doesn't sheet off as well as I was expecting, and I get wiper blade shudder when there's only a little water to wipe away.

I didn't clay the glass or anything, as it's only 6 weeks old so I figured there's not going to be much in the form of bonded contaminants yet. Perhaps that's where I messed up?
What product was on the screen beforehand ?

Fast glass will not remove remnants of previous coatings.
percymon is offline   Reply With Quote
Old 14-02-2018, 05:15 PM   #5
bigbruiser
Orbital Oracle
 
bigbruiser's Avatar
 
Join Date: Apr 2016
Posts: 564
Thanks: 73
Thanked 270 Times in 217 Posts
Quote:
Originally Posted by Andyblue View Post
The powder version of Bar Keepers friend is brilliant stuff

I stopped using any products on my windscreen due to smearing and some judder at low speeds - I tried everything I could think of and always had the issue...

I use my stuff on side / rear windows now and it’s great.
Andy I chanced some tough seal on the wife's used ipa wash before happy so far no smear or judder
bigbruiser is offline   Reply With Quote
The Following User Says Thank You to bigbruiser For This Useful Post:
Andyblue (14-02-2018)
Old 14-02-2018, 05:30 PM   #6
great gonzo
Distinguished Detailer
 
great gonzo's Avatar
 
Join Date: Nov 2010
Location: Reigate Surrey.
Posts: 8,626
Thanks: 2,716
Thanked 3,269 Times in 2,422 Posts
Had it dried/cured totally?
10 minuets doesn’t sound long enough with these cold temps we are having.


Gonz.
great gonzo is offline   Reply With Quote
Old 14-02-2018, 05:56 PM   #7
Alan W
Distinguished Detailer
 
Alan W's Avatar
 
Join Date: May 2006
Location: Southside
Posts: 7,109
Thanks: 1,205
Thanked 2,925 Times in 2,247 Posts
Garage
I apply a second coat after the first has cured (use the finger swipe test) before buffing off and haven't had any problems.

Use a damp MF if you have and difficulty buffing the product off.

A great sealant given the modest cost.

Alan W
Alan W is offline   Reply With Quote
Old 14-02-2018, 06:09 PM   #8
planehazza
Sponge Jockey
 
Join Date: Jan 2018
Posts: 47
Thanks: 4
Thanked 2 Times in 2 Posts
Thanks, guys, a few things to try. Unless there was a factory product on, which I doubt, as there was no hydrophobic effect, there was nothing on prior.
planehazza is offline   Reply With Quote
The Following User Says Thank You to planehazza For This Useful Post:
Andyblue (14-02-2018)
Old 14-02-2018, 06:13 PM   #9
Andyblue
OCD Sufferer (Obsessive Car Detailer)
 
Andyblue's Avatar
 
Join Date: Jun 2017
Location: In the Dog house
Posts: 3,768
Thanks: 1,272
Thanked 1,741 Times in 1,544 Posts
Quote:
Originally Posted by bigbruiser View Post
Andy I chanced some tough seal on the wife's used ipa wash before happy so far no smear or judder

Cheers bud - might give that a go.

Need to get some ipa now
Andyblue is offline   Reply With Quote
Old 14-02-2018, 09:42 PM   #10
mawallace
Washmitt Meister
 
Join Date: Apr 2017
Location: Suffolk
Posts: 278
Thanks: 4
Thanked 15 Times in 13 Posts
As am aside what's the curing time of h2go this time of year for the side and rear window
mawallace is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 07:16 PM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
DTO Garage vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors
Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
DTO Garage vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors