Detailing World  

Go Back   Detailing World > Detailing Products > Polish/Cleaners/Compounds/Glaze
DW Home Forum Home Merchandise Store Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Polish/Cleaners/Compounds/Glaze Discuss Polish/Cleaners/Compounds and Glaze here - Sponsored By g3pro

Reply
 
Thread Tools Display Modes
Old 23-08-2016, 02:27 PM   #11
steelghost
Detailing at Double Speed
 
steelghost's Avatar
 
Join Date: Aug 2015
Location: Stockport
Posts: 5,481
Thanks: 1,993
Thanked 2,761 Times in 2,067 Posts
Garage
Did you give it a really good shake first?
steelghost is offline   Reply With Quote
Old 23-08-2016, 02:30 PM   #12
vulf1986
Sponge Jockey
 
vulf1986's Avatar
 
Join Date: Jan 2016
Posts: 72
Thanks: 32
Thanked 23 Times in 18 Posts
Yeah massive shake, keep shaking it now but it's like the water liquid won't bond woth the compound. Just wasn't sure if anyone else has experienced this with the S20

Sent from my E6853 using Tapatalk
vulf1986 is offline   Reply With Quote
Old 23-08-2016, 02:49 PM   #13
justina3
OCD Sufferer (Obsessive Car Detailer)
 
Join Date: Jan 2008
Location: swansea
Posts: 2,130
Thanks: 290
Thanked 894 Times in 703 Posts
Send a message via MSN to justina3
My S20 doesnt look anything like that, mine is a lot lighter a grey almost and all the same colour
justina3 is offline   Reply With Quote
Old 23-08-2016, 02:49 PM   #14
Jonny_R
OCD Sufferer (Obsessive Car Detailer)
 
Jonny_R's Avatar
 
Join Date: Oct 2012
Location: Ormskirk
Posts: 2,908
Thanks: 430
Thanked 986 Times in 839 Posts
Am i missing something here?

Surely if you have the AF system you can just use one of the polishes and pads (least aggressive) and go from there? Dont have to use all 3 steps and polishes.

Dont have any experience with S20 myself either, but definitly doesnt sound right. I use all Scholl polishes S30 S17 S3 etc and never had that issue with them
Jonny_R is offline   Reply With Quote
Old 23-08-2016, 02:51 PM   #15
Welshquattro1
OCD Sufferer (Obsessive Car Detailer)
 
Welshquattro1's Avatar
 
Join Date: Dec 2013
Location: South Wales
Posts: 2,162
Thanks: 2,508
Thanked 1,256 Times in 935 Posts
Garage
Perhaps it's this?
http://www.detailingworld.co.uk/foru...ghlight=Scholl
Welshquattro1 is offline   Reply With Quote
The Following User Says Thank You to Welshquattro1 For This Useful Post:
vulf1986 (23-08-2016)
Old 23-08-2016, 03:04 PM   #16
vulf1986
Sponge Jockey
 
vulf1986's Avatar
 
Join Date: Jan 2016
Posts: 72
Thanks: 32
Thanked 23 Times in 18 Posts
Quote:
Originally Posted by Welshquattro1 View Post
Sounds exactly the same. I'll quit with ot for now as I don't want to damage my paint

Sent from my E6853 using Tapatalk
vulf1986 is offline   Reply With Quote
Old 23-08-2016, 03:08 PM   #17
vulf1986
Sponge Jockey
 
vulf1986's Avatar
 
Join Date: Jan 2016
Posts: 72
Thanks: 32
Thanked 23 Times in 18 Posts
Quote:
Originally Posted by Jonny_R View Post
Am i missing something here?

Surely if you have the AF system you can just use one of the polishes and pads (least aggressive) and go from there? Dont have to use all 3 steps and polishes.

Dont have any experience with S20 myself either, but definitly doesnt sound right. I use all Scholl polishes S30 S17 S3 etc and never had that issue with them
The reason I've tried Scholl is someone on here advised me it wouldn't need the 3 or even 2 steps of the AF kit so thought I'd give it a try. Back to good old AF for now though

Sent from my E6853 using Tapatalk
vulf1986 is offline   Reply With Quote
The Following User Says Thank You to vulf1986 For This Useful Post:
Jonny_R (23-08-2016)
Old 23-08-2016, 04:34 PM   #18
vulf1986
Sponge Jockey
 
vulf1986's Avatar
 
Join Date: Jan 2016
Posts: 72
Thanks: 32
Thanked 23 Times in 18 Posts
Update on the S20, called Scholl and they confirmed a faulty batch from the number I had. They are sending me a new one for Thursday and a 5.5 purple spider pad as an apology. Thought I was going mad!

Sent from my E6853 using Tapatalk
vulf1986 is offline   Reply With Quote
Old 23-08-2016, 05:39 PM   #19
steelghost
Detailing at Double Speed
 
steelghost's Avatar
 
Join Date: Aug 2015
Location: Stockport
Posts: 5,481
Thanks: 1,993
Thanked 2,761 Times in 2,067 Posts
Garage
Quote:
Originally Posted by vulf1986 View Post
Update on the S20, called Scholl and they confirmed a faulty batch from the number I had. They are sending me a new one for Thursday and a 5.5 purple spider pad as an apology. Thought I was going mad!

Sent from my E6853 using Tapatalk
Good to hear they're sorting you out
steelghost is offline   Reply With Quote
The Following User Says Thank You to steelghost For This Useful Post:
vulf1986 (23-08-2016)
Old 23-08-2016, 11:23 PM   #20
Welshquattro1
OCD Sufferer (Obsessive Car Detailer)
 
Welshquattro1's Avatar
 
Join Date: Dec 2013
Location: South Wales
Posts: 2,162
Thanks: 2,508
Thanked 1,256 Times in 935 Posts
Garage
Glad you got it sorted in the end
Welshquattro1 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 01:37 AM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
DTO Garage vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors
Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
DTO Garage vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors