Detailing World  

Go Back   Detailing World > Detailing Products > Tools -Machine polishers, Pressure Washers, Detailing Equipment & Microfiber
DW Home Forum Home Merchandise Store Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Tools -Machine polishers, Pressure Washers, Detailing Equipment & Microfiber Sponsored by Detailed Clean : www.DetailedClean.co.uk – | Bilt Hamber | Dodo Juice | Nanolex | Sonus | Wolfs Chemicals + More | Loyalty Scheme Discounts |

Reply
 
Thread Tools Display Modes
Old 30-06-2018, 10:43 PM   #1
Danjc
OCD Sufferer (Obsessive Car Detailer)
 
Danjc's Avatar
 
Join Date: Dec 2013
Posts: 1,103
Thanks: 625
Thanked 714 Times in 402 Posts
Garage
Nilfisk 130.3 pump running continuously

Today I changed the water inlet as the two recesses that the u pin slide over were worn and it was blowing out upon first start up.
But now the pump just runs continuously if the trigger is pulled on the lance or not and isn’t shutting off as it should upon trigger release.
I have done a little research and it sounds like either or both the microswitch and start stop valve but can’t be sure ?
Has anyone any idea or guidance etc before I start pulling it apart.

Last edited by Danjc; 01-07-2018 at 12:29 AM.
Danjc is offline   Reply With Quote
Old 01-07-2018, 12:29 AM   #2
neilmcl
OCD Sufferer (Obsessive Car Detailer)
 
Join Date: Mar 2010
Posts: 1,256
Thanks: 241
Thanked 441 Times in 342 Posts
Could be just an air leak somewhere, possibly where you've changed the inlet valve.
neilmcl is offline   Reply With Quote
Old 01-07-2018, 12:55 AM   #3
OvEr_KiLL
OCD Sufferer (Obsessive Car Detailer)
 
OvEr_KiLL's Avatar
 
Join Date: Mar 2015
Posts: 4,174
Thanks: 2,009
Thanked 1,527 Times in 1,272 Posts
clean filter in the water inlet? on my c130 it pulls out
OvEr_KiLL is offline   Reply With Quote
Old 02-07-2018, 09:21 AM   #4
Vmlopes
Washmitt Meister
 
Join Date: Jan 2012
Location: Reading, Berkshire
Posts: 208
Thanks: 21
Thanked 112 Times in 66 Posts
Check the o-ring on the hose to lance connection
Vmlopes is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 05:08 AM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
DTO Garage vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors
Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
DTO Garage vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors