Detailing World

Detailing World (http://www.detailingworld.co.uk/forum/index.php)
-   Interior & Glass (http://www.detailingworld.co.uk/forum/forumdisplay.php?f=11)
-   -   Help! Weird stuff on leather seats (http://www.detailingworld.co.uk/forum/showthread.php?t=415856)

Pollyonion 23-08-2019 12:30 PM

Help! Weird stuff on leather seats
 
When I bought my BMW Z4 in January there was, what looked like, dirt on the passenger seat. It hadn't been valeted very well. I tried to clean it off but it doesnt budge and it seems to be spreading.
I think it may be a mould of some sort and really don't know what to do.
Any advice would be great. It's still in warranty - my husband thinks it's dirt and that I'm being precious.

camerashy 23-08-2019 12:40 PM

Any photo would help

Andyblue 23-08-2019 01:06 PM

As above, photo would help greatly

Could be ingrained dirt, could be due transfer from jeans say..,

What have you used to clean it ?

Pollyonion 23-08-2019 01:10 PM

This is my first ever thread post- I tried to upload photos but it kept failing. Any idea what I could be doing wrong?

Pollyonion 23-08-2019 01:11 PM

I used Lord Sheraton Leather Balsam and Simoniz leather wipes

Pollyonion 23-08-2019 01:12 PM

The marks are on the upright back, not the sitting base

camerashy 23-08-2019 04:14 PM

Quote:

Originally Posted by Pollyonion (Post 5583695)
This is my first ever thread post- I tried to upload photos but it kept failing. Any idea what I could be doing wrong?

What platform are you using.
Most people use Imgur for photo uploads
Once you have uploaded the photos to imgur copy the BBC code and paste into your reply on here.
So as to ensure the images are the right size put a L (capital L) before the .jpg before you finish.

camerashy 23-08-2019 04:31 PM

LTT Leather and Colourlock are two very good companies/websites to visit.
It sounds as if the leather would need to be cleaned first and then treated with a Maintain/
Conditioning coating.

https://www.colourlock.com/leather-c...er-shield.html

Andyblue 23-08-2019 07:29 PM

Quote:

Originally Posted by Pollyonion (Post 5583695)
This is my first ever thread post- I tried to upload photos but it kept failing. Any idea what I could be doing wrong?



I use Tapatalk and itís easy to just add the photo to the post / thread. :thumb:

Pollyonion 24-08-2019 01:54 PM

Hi, thank you for the responses so far and the tech.help.
Seat 1 https://imgur.com/a/R677u2d
Here is the link to the picture.


All times are GMT +1. The time now is 08:02 AM.

Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

DTO Garage vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors