Detailing World  

Go Back   Detailing World > Technical > Help..!
DW Home Forum Home Merchandise Store Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Help..! Questions relating to products and how to use them.

Reply
 
Thread Tools Display Modes
Old 04-03-2014, 03:05 PM   #1
.Martin
Orbital Oracle
 
.Martin's Avatar
 
Join Date: May 2007
Location: Thurso, Caithness
Posts: 617
Thanks: 631
Thanked 125 Times in 48 Posts
Unhappy HD Lance Help Please

Gents,

I've just logged on after quite a hiatus to look for some help

I went to use my foam lance yesterday for the first time (owned it over a year but due to a broken leg never got round to using it). Inch and a half of MagiFoam with three quarters of a bottle of hot water.

Connected it to the Karcher, switched on and waited for the magic to happen......

NOTHING

Tried turning the + / - dial on the top to see if that made any difference but again nothing. Is the screw inside that dial supposed to turn when you turn the dial?

Help me please and I promise not to leave it so long before posting.
.Martin is offline   Reply With Quote
Old 09-03-2014, 07:59 AM   #2
.Martin
Orbital Oracle
 
.Martin's Avatar
 
Join Date: May 2007
Location: Thurso, Caithness
Posts: 617
Thanks: 631
Thanked 125 Times in 48 Posts
Bump
.Martin is offline   Reply With Quote
Old 09-03-2014, 08:05 AM   #3
Puntoboy
OCD Sufferer (Obsessive Car Detailer)
 
Puntoboy's Avatar
 
Join Date: Jun 2007
Location: Kettering, Northamptonshire
Posts: 4,040
Thanks: 1,101
Thanked 1,192 Times in 843 Posts
Garage
Send a message via MSN to Puntoboy
There's a guide on here that describes taking it apart. Take a look at that.

Have you never used it since purchase? Not even to try it? Typically it's a blocked gauze that causes issues.
Puntoboy is offline   Reply With Quote
Old 09-03-2014, 08:31 AM   #4
alan hanson
OCD Sufferer (Obsessive Car Detailer)
 
alan hanson's Avatar
 
Join Date: May 2008
Posts: 3,683
Thanks: 706
Thanked 1,092 Times in 904 Posts
as above the metal gauzed get clogged had the same as you soaked this over night and worked perfect the next day
alan hanson is offline   Reply With Quote
Old 09-03-2014, 04:05 PM   #5
steve from wath
Distinguished Detailer
 
Join Date: Dec 2008
Posts: 5,992
Thanks: 1,803
Thanked 2,892 Times in 1,924 Posts
heres a video i made to show how to strip down etc

the little screw you can see,this attaches the adjuster knob to the spindle
if the black plastic knob just spins then it sounds like either
the screw has shearhed off or the unside of the adjuster has a recess shaped to the spindle,this could also be at fault

have alook at video ,

http://www.detailingworld.co.uk/foru...d.php?t=304139
steve from wath is offline   Reply With Quote
Reply

Tags
autobrite, foam, hd lance, snow foam


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 02:32 PM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
DTO Garage vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors
Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
DTO Garage vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors