Detailing World Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1,390 Posts
Discussion Starter · #1 ·
Hello people,

Had my first proper play with my new Nilfisk C120 at the weekend there and whilst I was impressed with it overall, there is a slight concern.

Whenever I release the trigger after spraying, a slight squeaking noise comes from the body of the machine...

Does anyone know what this is??

Cheers
V3
 

·
Registered
Joined
·
3,042 Posts
I used my brand new E120.1 at the weekend with the same too.

Its the machine moving!

After rinsing the full car and numerous squeeks after releasing, the machine had nearly turned 90 degrees on its own accord

The squeek i found out to be from one of the wheels (right hand side of machine when facing it) moving under the movement of releasing the trigger and the pump stopping
 

·
Registered
Joined
·
3,042 Posts
my wheels dont squeek dragging it around but the machine definitly moves on its own when releasing so assumed it was the wheel being jolted.

Could be the pump inside though tbh but im in the same boat
 

·
Registered
Joined
·
3,042 Posts
Just abit of an update on this OP

Mine continued to do it up until the last time i used my machine.

Ive got a rubber replacement hose from Direct Hoses (Steve from Wath of here's mate) and my machine no longer makes the squeek noise with the new hose! So can only assume it is something to do with the original supplied thermoplastic hose.
 

·
Registered
Joined
·
1,390 Posts
Discussion Starter · #7 ·
Hmmm nice!

I actually got it checked out by an authorised Nilfisk repair guy and he said it's perfectly normal because it is an aluminium pump but I'll keep that in mind
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top